Configuré betaflight y funciono hasta que lo desconecte

Todo sobre los nuevos drones de carreras ayudas y nuevos modelos y todo sobre Betaflight
FernandoJ
Subteniente del Aire
Subteniente del Aire
Mensajes: 8
Registrado: Octubre 28th, 2019, 3:24 pm

Configuré betaflight y funciono hasta que lo desconecte

Mensaje por FernandoJ » Octubre 28th, 2019, 3:52 pm

Hola, me compre un dron por piezas, un frame que me gustó y el resto como el video "COMO MONTAR UN DRONE DE CARRERAS PASO A PASO". La controladora de vuelo es la SPracingF3 como la de los videos de betaflight and beer. El caso es que seguí los pasos y mientras tuve enchufada la controladora por usb al ordenador todo parecía ir bien pero cuando la desenchufo no funciona. Tengo claro que algo no hago bien o simplemente me he cargado la controladora, ¿que pensáis que puede ser?
Tengo que reconocer que no soy un virtuoso del "soldering"

Gracias.

Avatar de Usuario
Raulbbx
Capitán del Aire
Capitán del Aire
Mensajes: 254
Registrado: Septiembre 2nd, 2019, 6:47 pm

Re: Configuré betaflight y funciono hasta que lo desconecte

Mensaje por Raulbbx » Octubre 28th, 2019, 7:43 pm

Pues hombre, si nos das un poco más de info lo mismo podemos ayudar...

Que pasa?

No te arma?

No te reconoce la emisora?

No hace el ruido del check de la controladora o los esc?

Que dron es?

Componentes?

Tienes alimentación en la controladora vía lipo?

Y ya a modo personal, como pillas una F3 loco???

Avatar de Usuario
fjbf98
Brigadier General del Aire
Brigadier General del Aire
Mensajes: 820
Registrado: Mayo 5th, 2019, 3:42 am

Re: Configuré betaflight y funciono hasta que lo desconecte

Mensaje por fjbf98 » Octubre 29th, 2019, 5:40 am

Cuando la configurabas, le daba a grabar " SAVE ".

Un saludo

Juande
Brigadier General del Aire
Brigadier General del Aire
Mensajes: 888
Registrado: Abril 12th, 2017, 3:04 am

Re: Configuré betaflight y funciono hasta que lo desconecte

Mensaje por Juande » Octubre 29th, 2019, 6:53 am

FernandoJ escribió:
Octubre 28th, 2019, 3:52 pm
El caso es que seguí los pasos y mientras tuve enchufada la controladora por usb al ordenador todo parecía ir bien pero cuando la desenchufo no funciona.
Aquí aplica la vieja máxima de la informática: funciona mejor si lo enchufas. :D

Ahora... Describe el problema como para un niño de 7 años. Básicamente que haces (no me vale "lo enchufo", dime que enchufas, donde lo enchufas, como lo enchufas y con cuanto cariño lo enchufas, ya que estamos), que esperabas que hiciera y que es lo que hace.

Por tu descripción que pusiste podría se una bombilla: Oye, que cuando la enchufo brilla, pero cuando no la enchufo no luce. ¿Que puede ser? :D

FernandoJ
Subteniente del Aire
Subteniente del Aire
Mensajes: 8
Registrado: Octubre 28th, 2019, 3:24 pm

Re: Configuré betaflight y funciono hasta que lo desconecte

Mensaje por FernandoJ » Octubre 30th, 2019, 4:55 am

Pues compré una f3,como todo lo demás, porque no tengo ni p. idea. Fuí viendo videos y precios y compré.
Mi configuración es la siguiente:
Frame: HSKRC Freestyle 250 248mm Carbon Fiber
Esc: 4X Racerstar RS30A V2 30A Blheli_S ESC OPTO 2-4S Support Oneshot42 Multishot 16.5 Dshot600
Motores: 4X Racerstar Racing Edition 2205 BR2205 2300KV 2-4S Brushless Motor
PDB: Matek Mini Power Hub Power Distribution Board PDB With BEC 5V And 12V
FC: SPracingF3

Emisora: RadioLink AT9S 2.4GHz 10CH
receptor: Radiolink R6DSM 2.4G 10CH

No he instalado cámara porque pensé que primero conseguir que vuele y luego añadirle lo demás.

Enchufo vía usb al ordenador. Hago el proceso de calibración y configuración y funciona el receptor y motores. Salvo varias veces en el proceso. Doy al botón de desconectar, cierro la aplicación betaflight y desconecto el usb. La batería que conecté para probar y ajustar receptor y motores sigue enchufada. Desenchufo batería, vuelvo a enchufar y no engancha, nada funciona. Abro la aplicación betaflight, conecto vía usb al ordenador intento conectar y da error. Hice lo del boot y después el resto del proceso con exactamente el mismo resultado.

Muchas gracias.

Juande
Brigadier General del Aire
Brigadier General del Aire
Mensajes: 888
Registrado: Abril 12th, 2017, 3:04 am

Re: Configuré betaflight y funciono hasta que lo desconecte

Mensaje por Juande » Octubre 30th, 2019, 5:21 am

Así, a bote pronto, lo primero que se me ocurre es que al poner la batería has frito la controladora por no haber conectado algo bien.

Damos por supuesto que no ha habido "humo mágico" porque lo habrías comentado.

Vamos a probar cosas:

1.- Conecta la controladora por USB. ¿Se enciende algún led? En la placa y/o en el receptor. Si no se encienda nada... Pues ya tienes una buena excusa para pillarte una F4 nueva... ;)

2.- Luego... Si hay luces. Desconecta la FC de los ESC. Pon la batería. ¿Los ESC pitan? Deberían dar tres pitidos.

FernandoJ
Subteniente del Aire
Subteniente del Aire
Mensajes: 8
Registrado: Octubre 28th, 2019, 3:24 pm

Re: Configuré betaflight y funciono hasta que lo desconecte

Mensaje por FernandoJ » Octubre 30th, 2019, 5:34 am

Por cierto la luz de power en la FC se enciende tanto cuando está conectada con el usb como con la batería aunque no tenga usb. La luz de status solo se mantiene encendida mientras la configuro. Una vez desconectado del ordenador conecto la batería y parpadea con varios flashes a diferente ritmo durante unos segundo y se apaga. ....

FernandoJ
Subteniente del Aire
Subteniente del Aire
Mensajes: 8
Registrado: Octubre 28th, 2019, 3:24 pm

Re: Configuré betaflight y funciono hasta que lo desconecte

Mensaje por FernandoJ » Octubre 30th, 2019, 6:42 am

Los esc desconectados de la FC hacen lo mismo que conectados no pitan, hay una musiquilla inicial pero no pitidos...

Juande
Brigadier General del Aire
Brigadier General del Aire
Mensajes: 888
Registrado: Abril 12th, 2017, 3:04 am

Re: Configuré betaflight y funciono hasta que lo desconecte

Mensaje por Juande » Octubre 30th, 2019, 10:33 am

FernandoJ escribió:
Octubre 30th, 2019, 6:42 am
Los esc desconectados de la FC hacen lo mismo que conectados no pitan, hay una musiquilla inicial pero no pitidos...
Bueno... La "musiquilla" deben de ser los 3 primeros tonos que dan los ESC. Te faltan los otros dos que indican que los ESC están hablando con la controladora.

Sube fotos de las conexiones del 4en1 con la controladora de vuelo.

FernandoJ
Subteniente del Aire
Subteniente del Aire
Mensajes: 8
Registrado: Octubre 28th, 2019, 3:24 pm

Re: Configuré betaflight y funciono hasta que lo desconecte

Mensaje por FernandoJ » Octubre 30th, 2019, 11:11 am

FC conexiones ESC copia.jpg
Los cables blancos cortados son, o eran, de los ESC. Como los tengo soldados para probar más rápido los he cortado.


Responder

Volver a “Foro Drones De Carreras y Betaflight”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado