Página 1 de 1

Motores giran sin control y descoordinados Eachine Tyro99

Publicado: Julio 13th, 2020, 11:59 am
por Condemacizo
Hola soy nuevo en este mundo y monté hace pocos días mi primer dron, un Eachine Tyro99. Todo parecía que iba bien ( seguía todos los pasos y todo parecía que funcionaba) hasta que cuando ya tengo el dron montado activo por primera vez el armado y los motores giran sin control, a gran velocidad (mucha más de la que Configuré en betafly) y cada uno a una velocidad diferente todo el rato. Llevo 2 días revisando y probando todo y no doy con el problema (los motores giran en el sentido correcto, las palas están bien puestas, giroscopio y acelerómetro bien calibrados, mando bien conectado). Los motores giran bien si los hago girar desde betaflight pero cuando es con el mando no. Se me ha quemado el variador 4 en 1? Por que otra cosa no se me ocurre. Si alguien sabe se agradece la ayuda estoy desesperado. Si eso puedo pasar algún video

Re: Motores giran sin control y descoordinados

Publicado: Julio 17th, 2020, 3:15 am
por Juande
Condemacizo escribió:
Julio 13th, 2020, 11:59 am
Hola soy nuevo en este mundo y monté hace pocos días mi primer dron, un tyro99. Todo parecía que iba bien ( seguía todos los pasos y todo parecía que funcionaba) hasta que cuando ya tengo el dron montado activo por primera vez el armado y los motores giran sin control, a gran velocidad (mucha más de la que Configuré en betafly) y cada uno a una velocidad diferente todo el rato. Llevo 2 días revisando y probando todo y no doy con el problema (los motores giran en el sentido correcto, las palas están bien puestas, giroscopio y acelerómetro bien calibrados, mando bien conectado). Los motores giran bien si los hago girar desde betaflight pero cuando es con el mando no. Se me ha quemado el variador 4 en 1? Por que otra cosa no se me ocurre. Si alguien sabe se agradece la ayuda estoy desesperado. Si eso puedo pasar algún video
Empieza por revisar la configuración de los ESC en betaflight. Mira que esté en DSHOT. Si lo está, prueba a bajar el número (si está en DSHOT600 baja al siguiente número que te deje).

Luego revisa los motores desde Betaflight, pestaña motores. Primero uno por uno, luego sube los 4 a la vez y verifica que giran a la misma velocidad.

Por último, pon el dron en modo acro y mira si se "arregla". Si es así, es que tienes algún problema con el acelerómetro.

Salu2!

Re: Motores giran sin control y descoordinados Eachine Tyro99

Publicado: Julio 25th, 2020, 8:31 am
por Condemacizo
lo he hecho pero aun sigue fallando, probé a flashear la placa a la ultima version MATEKF405 v 4.1.1 y nada.

Re: Motores giran sin control y descoordinados Eachine Tyro99

Publicado: Julio 26th, 2020, 6:19 am
por Condemacizo
Condemacizo escribió:
Julio 13th, 2020, 11:59 am
Hola soy nuevo en este mundo y monté hace pocos días mi primer dron, un Eachine Tyro99. Todo parecía que iba bien ( seguía todos los pasos y todo parecía que funcionaba) hasta que cuando ya tengo el dron montado activo por primera vez el armado y los motores giran sin control, a gran velocidad (mucha más de la que Configuré en betafly) y cada uno a una velocidad diferente todo el rato. Llevo 2 días revisando y probando todo y no doy con el problema (los motores giran en el sentido correcto, las palas están bien puestas, giroscopio y acelerómetro bien calibrados, mando bien conectado). Los motores giran bien si los hago girar desde betaflight pero cuando es con el mando no. Se me ha quemado el variador 4 en 1? Por que otra cosa no se me ocurre. Si alguien sabe se agradece la ayuda estoy desesperado. Si eso puedo pasar algún video
He conseguido arreglar las oscilaciones en el armado bajando los pids del yaw pero aun tengo el problema al acelerar. Cuando acelero un poquito algunos motores se ponen a la mitad de potencia y luego bajan y suben continuamente, es decir cada motor gira a una velocidad diferente y no constante cuando subo muy poco la palanca del gas y no la toco. los ESC estan sincronizados y puestos en DSHOT 600, el mando tambien esta bien configurado y el dron recibe bien la señal del mando. Se me esta escapando algo o tengo algo roto en el dron?

Re: Motores giran sin control y descoordinados Eachine Tyro99

Publicado: Agosto 18th, 2020, 4:14 am
por Juande
Condemacizo escribió:
Julio 26th, 2020, 6:19 am

He conseguido arreglar las oscilaciones en el armado bajando los pids del yaw pero aun tengo el problema al acelerar. Cuando acelero un poquito algunos motores se ponen a la mitad de potencia y luego bajan y suben continuamente, es decir cada motor gira a una velocidad diferente y no constante cuando subo muy poco la palanca del gas y no la toco. los ESC estan sincronizados y puestos en DSHOT 600, el mando tambien esta bien configurado y el dron recibe bien la señal del mando. Se me esta escapando algo o tengo algo roto en el dron?
Haz la pruebas desde la pestaña de motores de Betaflight.

Cambia a DSHOT 300 y vuelve a probar.

Apunta que motor te hace cosas raras. Si son varios, apunta el que va bien y permutalo con el opuesto que te hace cosas raras. Si el error cambia de lugar, problema de motor. Si el error sigue en la pata con el motor "bueno", problema de ESC.

Yo apuesto por motores cascados.